elasticsearch安装过程踩的坑整理

简介 总结安装es遇到的坑。一:ES版本与JDK版本不一致凯哥在第一次安装ES的时候,打开ES官网看到最新版本是7.6。因为不知道ES与JDK版本有对应关系。本地1.8的JDK。安装的时候,一堆错误。然后各种搜索,查看官网才发现JDK版本不一致导致。于是果断更换ES版本。解决办法:更换符合自己JDK版本的ES二:启动的时候提示权限不足在启动ES的时候提示权限不足编辑原因:ES不能使用root用户。解决方

总结安装es遇到的坑。

一:ES版本与JDK版本不一致

凯哥在第一次安装ES的时候,打开ES官网看到最新版本是7.6。因为不知道ES与JDK版本有对应关系。本地1.8的JDK。安装的时候,一堆错误。然后各种搜索,查看官网才发现JDK版本不一致导致。于是果断更换ES版本。

解决办法:更换符合自己JDK版本的ES

二:启动的时候提示权限不足

在启动ES的时候提示权限不足

编辑

原因:ES不能使用root用户。

解决方法:创建es用户。

三:ES不能外网访问

更换ES之后,再次安装后,用localhost能够访问,但是通过ip+端口就不能访问了。

解决办法:elasticsearch.yml中第55行。设置host.

四:进程数量限制

错误信息1:max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]

或者是:

max number of threads [1024] for user [lishang] likely too low, increase to at least [2048]

错误信息2:max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

错误1解决:

切换到root用户,编辑limits.conf 添加类似如下内容

vi /etc/security/limits.conf

添加如下内容:

* soft nofile 65536

* hard nofile 131072

* soft nproc 4096

* hard nproc 4096

错误2解决:

解决:切换到root用户修改配置sysctl.conf

vi /etc/sysctl.conf

添加下面配置:

vm.max_map_count=655360

并执行命令:

sysctl -p


Top Top