The temporary upload location [/tmp/tomcat.***/work/Tomcat/localhost/ROOT] is not valid
今天突然收到错误反馈文件上传失败了。错误如下图:Failedtoparsemultipartservletrequest;nestedexceptionisjava.io.IOException:Thetemporaryuploadlocation[/tmp/tomcat.2108414996593143912.8080/work/Tomcat/localhost/ROOT]isnotvalid这
今天突然收到错误反馈文件上传失败了。错误如下图:

Failed to parse multipart servlet request; nested exception is java.io.IOException: The temporary upload location [/tmp/tomcat.2108414996593143912.8080/work/Tomcat/localhost/ROOT] is not valid
这个问题之前没遇到过啊。然后BXX后,网上还真有人遇到。原因分析:
原因:在linux系统中,springboot应用服务再启动(java -jar 命令启动服务)的时候,会在操作系统的/tmp目录下生成一个tomcat*的文件目录,上传的文件先要转换成临时文件保存在这个文件夹下面。由于临时/tmp目录下的文件,在长时间(10天)没有使用的情况下,就会被系统机制自动删除掉。所以
原创不易,完成人机校验,阅读全文
相关推荐
DOCKER【已解决】在docker里面安装es时候提示IPv4 forwarding is disabled. Networking will not work.工作小总结【已解决】SQLite 共享访问时候提示:The database file is locked (database is locked)CI/CDJenkins初始化界面一直显示Please wait while Jenkins is getting ready to work ...DOCKERwindows环境下使用docker pull 提示:Using default tag: latest error during connect: This error may indicate that the docker daemon is not running.: Post DOCKER【已解决】Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?学习笔录-SPRING BOOTspring boot template might not exist or might not be accessible by any of the configured Template Resolvers错误AI相关解决dify添加代码节点时候错误信息:Run failed: Failed to execute code, which is likely a network issue, please check if the sandbox service is running. ( Error: [Errno -2] Name or service not known )经验分享【已解决】项目启动,报错:java.sql :Public Key Retrieval is not allowed