MYSQL

【已解决】MySQL 8.0 免安装版在mysqld --install 时候提示:Install/Remove of the Service Denied!

从Oracle官网下载了:https://cdn.mysql.com//Downloads/MySQL-8.0/mysql-8.0.32-winx64.zip解压之后,想安装成Windows服务,提示如下:感觉好像是是权限不够。那么使用管理员运行cmd,然后在执行上面命令,依然是不行了。问题原因:缺少my.ini文件进入MySQL目录,里面是缺少了配置文件my.ini,我们需要自己创建。在这里配置

从Oracle官网下载了:https://cdn.mysql.com//Downloads/MySQL-8.0/mysql-8.0.32-winx64.zip

解压之后,想安装成Windows服务,提示如下:

6cc6c7fea8b9e0c2beecb609193a1e0c.png

感觉好像是是权限不够。那么使用管理员运行cmd,然后在执行上面命令,依然是不行了。

问题原因:缺少 my.ini文件

进入MySQL目录,里面是缺少了配置文件my.ini,我们需要自己创建。

a778eec19740fe480b2d896ad1541cf4.png

在这里配置文件有两种编写方式(如下):


第一种:

 打开my.ini 文件,将下方配置信息填入。

 basedir和datadir是你MySQL存放的位置,改成自己的。

port是MySQL的启动端口号,需要更改端口号就改这里。


使用这种方式不好的地方就是你MySQL文件夹更换了位置,你的配置文件的指向位置也要改,比较麻烦。

[mysqld]
basedir ="G:\mysql-8.0.30-winx64"
datadir ="G:\mysql-8.0.30-winx64\data"
port=3306
server_id =10
character-set-server=gbk
character_set_filesystem=gbk
[client]
port=3306
default-character-set=gbk
[mysqld_safe]
ti

原创不易,完成人机校验,阅读全文

相关推荐