【已解决】Redis分片集群在缩容的时候,执行删除节点命令提示:is not empty! Reshard data away and try again
Redis分片集群,扩容之后,需要进行缩容,在执行删除节点命令命令的时候,提示如下错误:isnotempty!Resharddataawayandtryagain提示[ERR]Node127.0.0.1:7004isnotempty!Resharddataawayandtryagain.说明,当前该节点还有哈希槽信息,我们需要重哈希移走所有的数据才行,接下来执行操作删除节点操作。这里顺便说下,删除
Redis分片集群,扩容之后,需要进行缩容,在执行删除节点命令命令的时候,提示如下错误:is not empty! Reshard data away and try again
提示[ERR] Node 127.0.0.1:7004 is not empty! Reshard data away and try again.说明,当前该节点还有哈希槽信息,我们需要重哈希移走所有的数据才行,接下来执行操作删除节点操作。
这里顺便说下,删除节点命令:
redis-cli --cluster del-node host:port node_id

解决方案:
我们将7004的哈希槽移动到7001上
原创不易,完成人机校验,阅读全文
相关推荐
REDIS【图文教程】Redis分片集群搭建DOCKER在docker中执行某些命令的时候 docker bash: xxx : command not found 通用解决方案工作小总结【已解决】使用spring boot链接sqlite的时候,并发写的时候提示:The database file is locked (database is locked)SOLRsolr错误【已解决】:solr is not an explicit field and doesn't match a dynamicFieldREDISRedis集群下批处理-串行化执行代码实践工作小总结【已解决】在使用mybatis的时候,怎么一次删除多个表工作小总结【已解决】SQLite 共享访问时候提示:The database file is locked (database is locked)DOCKER【已解决】在docker里面安装es时候提示IPv4 forwarding is disabled. Networking will not work.