DOCKER

docker高级篇1-dockeran安装mysql主从复制

本文咱们就先来实现第一个案例:mysql主从复制

大家好,咱们前面通过十篇的文章介绍了docker的基础篇,从本篇开始,咱们的《docker学习系列》将要进入到高级篇阶段(基础篇大家可以查看之前发布的文章)。

咱们先来介绍:docker复杂方式安装软件。通过按照mysql\redis两个案例来讲解

Docker复杂安装说明,两个案例:

1:安装mysql主从复制

2:安装redis集群

插播一条


下面这个公众号是凯哥开发的,福利号:外卖、买菜、电商领Q的

67db93da54df097b6017fa8666079592.png


本文咱们就先来实现第一个案例:mysql主从复制

f2f6cd061076b10def7e4d82efea9fc0.png

大家好,我是凯哥Java(kaigejava),乐于分享,每日更新技术文章,欢迎大家关注“凯哥Java”,及时了解更多。让我们一起学Java。也欢迎大家有事没事就来和凯哥聊聊~~~

安装mysql主从搭建步骤:

1:新建主服务器容器实例3307

命令

docker run -p 3307:3306 --name mysql-master \

-v /mydata/mysql-master/log:/var/log/mysql \

-v /mydata/mysql-master/data:/var/lib/mysql \

-v /mydata/mysql-master/conf:/etc/mysql \

-e MYSQL_ROOT_PASSWORD=root \

-d mysql:5.7

2:进入/mydata/mysql-master/conf目录下新建my.cnf

修改配置:

cd /mydata/mysql-master/conf

vim my.cnf

## 输入以下内容

[mysqld]

## 设置server_id,同一局域网中需要唯一

server_id=101

## 指定不需要同步的数据库名称

binlog-ignore-db=mysql  

## 开启二进制日志功能

log-bin=mall-mysql-bin  

## 设置二进制日志使用内存大小(事务)

binlog_cache_size=1M  

## 设置使用的二进制日志格式(mixed,statement,row)

binlog_format=mixed  

## 二进制日志过期清理时间。默认值为0,表示不自动清理。

expire_logs_days=7  

## 跳过主从复制中遇到的所有错误或指定类型的错误,避免slave端复制中断。

## 如:1062错误是指一些主键重复,1032错误是因为主从数据库数据不一致

slave_skip_errors=1062

注意文件权限应该是644

3:修改完配置之后重启master实例

修改完mysql配置后,记得重启实例

docker restart mysql-master

如果重启失败,查看是否因为my.conf文件写错导致。

或者查看错误日志: docker logs 容器id

45ae4951650045b830ac9fd85d270495.png

修改后,重新启动容器。

6bd2e69bbd7b3425623a5977f1cc6416.png

4:进入mysql-master容器

进入到mysql-master。然后登录m

原创不易,完成人机校验,阅读全文

相关推荐